I can't withdraw ETH to MetaMask

I deposited funds to DSA, #6718, contract https://etherscan.io/address/0x458E820A75f690f2DD46a8f3CA4D936b7327EA5d

I can’t withdraw funds back to my Metamask “owner” account.

When I click “Withdraw” and chose ETH, Max, I get a MM confirm that looks like that:

I then see a “Txn Pending” popup in my Dashboard window. The transaction is never found on Etherscan.

I tried increasing gas, withdrawing all my fund, only half of it. Nothing works.

Here is the last withdrawal I created: One for “max ETH”:

Any help?
What am I doing wrong?
Can I suppress the contract and recover my funds?

What wallet are you using? If you can’t find the transaction then we can’t also see anything, can you provide us the address so we can take a look? Or were you able to resolve this?

Hi Sebastian, problem solved, thank you

(not an instadapp issue, but a transaction queue issue in MM…)

Can you explain what the queue issue was?

EDIT : Nevermind. Not a queue issue but still a problem. Link to the post I created about it.

How did you solve this issue because I’m going through something similar with USDC

It had nothing to do with the app in the end. Was entirely my fault: I had a pending tx in Metamask that was preventing all following tx from happening.

I just had to reset my MM and restart the withdrawal and worked like a charm.

Hope that helps.
(if you don’t know how to “cancel transaction in metamask”, lookup in google, plenty of tutorials.)