Error on trading ETH to BAT

I tried multiple times to trade ETH to BAT, but everytime I get failed while txn execution. Please consider checking the below transactions,

0x1c791cc8d471e2d63db915b7a86875d74434f9af15ecf02533442380afdade82
0xc67bd3de8261992882a03e537cbdf19617ce0688fa49fb1636443fbff37fe2bc
0x239c8ff0a77d453054da7344a1c3d65a2dd3c2d320567b7eaae8e9e0ba96ed46
0xcf326442c8ac6271c4df3e37ec5bd06f7f35bf254cee90a62dc6bad44e776b9c
0x61e534608dfc730ea1ddddefe3c0cb60fa32e49abd71c8b8a870930fcd0e1a0f

Waiting for a quick resolution.

Regards
Mohneesh

Hi @mohneesh,

All TXs have the same error as shown, you need to set higher slippage on Kyber. Which could caused by large amount or long waiting time.

For trading better set normal/high gas and let it execute within half hour to prevent trade expiry or high slippage.

While trading I don’t see any option to modify the slippage, it says 0.0% and I’m keeping the gas fees as it is as suggested.

Please refer the attached image

Adding to @leckylao answer. We’re also soon going to add advance section on trade for users to set their own slippage. Currently, by default it’s 0.1%. but we’re thinking to increase it to 0.3% for non-stable coin pairs.